Unable to rebuild cache

Questions and discussion about PokerTracker 4 for Windows

Moderators: WhiteRider, kraada, Flag_Hippo, morny, Moderators

Unable to rebuild cache

Postby goldengummy0 » Mon Jun 15, 2020 11:13 am

I get the following error messasge: Unable to execute query: Fatal error; tables can have at most 1600 columns.

I think it's because I have too many huds installed right now, but I can't really delete any of them. How can I rebuild cache without removing any of my huds?
goldengummy0
 
Posts: 6
Joined: Wed May 01, 2013 8:08 am

Re: Unable to rebuild cache

Postby Flag_Hippo » Mon Jun 15, 2020 11:52 am

If you do not want to remove any of that content your only option is to manually disable the cache for some custom columns to get below the limit for cached columns in PostgreSQL:

Guide: Database Caching

Disabling the cache will mean any statistics using them will have to be calculated on demand which may mean delays in the HUD. If you do not know how many custom columns you currently have click your Windows Start button then type the following:

pgadmin

and click on it when it appears. Double click on "PostgreSQL x.y" (where x.y is your PostgreSQL version) and if your prompted for a password the default is "dbpass" (without the quotes). Next double click on "Databases -> YOUR_DATABASE_NAME -> Schemas -> Public -> Tables -> cash_custom_cache (and/or tourney custom cache for tournaments) and the number in brackets is the number of custom columns which should look like this.

Also please note that in some cases that number doesn't correlate directly to the number of cached columns which depends on the custom content you are using - you can see more about this in this thread and this thread.
Flag_Hippo
Moderator
 
Posts: 17049
Joined: Tue Jan 31, 2012 7:50 am

Re: Unable to rebuild cache

Postby goldengummy0 » Mon Jun 15, 2020 2:50 pm

Flag_Hippo wrote:If you do not want to remove any of that content your only option is to manually disable the cache for some custom columns to get below the limit for cached columns in PostgreSQL:

Guide: Database Caching

Disabling the cache will mean any statistics using them will have to be calculated on demand which may mean delays in the HUD. If you do not know how many custom columns you currently have click your Windows Start button then type the following:

pgadmin

and click on it when it appears. Double click on "PostgreSQL x.y" (where x.y is your PostgreSQL version) and if your prompted for a password the default is "dbpass" (without the quotes). Next double click on "Databases -> YOUR_DATABASE_NAME -> Schemas -> Public -> Tables -> cash_custom_cache (and/or tourney custom cache for tournaments) and the number in brackets is the number of custom columns which should look like this.

Also please note that in some cases that number doesn't correlate directly to the number of cached columns which depends on the custom content you are using - you can see more about this in this thread and this thread.


Thanks for your answer. So do I disable the cache of the columns by unclicking this?

[ img ]

The image doesn't load, I mean the cache square in the statistics window.

(Sorry I'm a fish with computers) But I don't see many new columns besides the ones that come with PT4 by default.

I've also just realized today none of my huds work on any site. Is it because of the same reason?
goldengummy0
 
Posts: 6
Joined: Wed May 01, 2013 8:08 am

Re: Unable to rebuild cache

Postby Flag_Hippo » Tue Jun 16, 2020 4:08 am

That sounds like most of your custom content is protected which means that it cannot be viewed/edited in PokerTracker 4 so to get below 1,600 columns you will need to contact one or more of your premium providers and have some content disabled so that PokerTracker 4 doesn't load it. Once you are below 1,600 custom columns you should be able to rebuild the database cache and your HUD should start working again. You can also remove the check mark from the PokerTracker 4 option 'Configure -> Options -> Download Premium Content' then close/restart PokerTracker 4 but this will disable all premium content.
Flag_Hippo
Moderator
 
Posts: 17049
Joined: Tue Jan 31, 2012 7:50 am

Re: Unable to rebuild cache

Postby dave2085 » Thu Jul 11, 2024 6:06 am

Hi,

is this limit, maximum of "1600" still existing for PostgreSQL 16.x?

I am using 16.x and with that guide:

"Double click on "PostgreSQL x.y" (where x.y is your PostgreSQL version) and if your prompted for a password the default is "dbpass" (without the quotes). Next double click on "Databases -> YOUR_DATABASE_NAME -> Schemas -> Public -> Tables -> cash_custom_cache (and/or tourney custom cache for tournaments) and the number in brackets is the number of custom columns which should look like this."

I cant see the number of custom columns. How can I see how many custom columns I am using?
dave2085
 
Posts: 202
Joined: Mon Jun 02, 2008 10:41 am

Re: Unable to rebuild cache

Postby Flag_Hippo » Thu Jul 11, 2024 6:28 am

dave2085 wrote:is this limit, maximum of "1600" still existing for PostgreSQL 16.x?

Yes:

https://www.postgresql.org/docs/current/limits.html

dave2085 wrote:"Double click on "PostgreSQL x.y" (where x.y is your PostgreSQL version) and if your prompted for a password the default is "dbpass" (without the quotes). Next double click on "Databases -> YOUR_DATABASE_NAME -> Schemas -> Public -> Tables -> cash_custom_cache (and/or tourney custom cache for tournaments) and the number in brackets is the number of custom columns which should look like this."

I cant see the number of custom columns. How can I see how many custom columns I am using?

Are you doing that via PGAdmin? I see the number of columns with PostgreSQL v16:

columns.PNG
(7.56 KiB) Downloaded 3256 times
Flag_Hippo
Moderator
 
Posts: 17049
Joined: Tue Jan 31, 2012 7:50 am

Re: Unable to rebuild cache

Postby dave2085 » Thu Jul 11, 2024 7:08 am

Thanks, found it :oops:

Cause I had issues in the past I am afraid to exceed the "1600" Limit.

Which tables are relevant to not exceed that (1600) limit?
Those four tables?:
cash_cache: 423
cash_custom_cache: 13
tourney_cache 399
tourney_custom_cache 426
dave2085
 
Posts: 202
Joined: Mon Jun 02, 2008 10:41 am

Re: Unable to rebuild cache

Postby Flag_Hippo » Thu Jul 11, 2024 1:08 pm

The 1,600 limit applies separately to each table. The tables that will change either by adding your own custom statistics or with the use of third party content are cash_custom_cache and/or tourney_custom_cache.
Flag_Hippo
Moderator
 
Posts: 17049
Joined: Tue Jan 31, 2012 7:50 am


Return to PokerTracker 4

Who is online

Users browsing this forum: No registered users and 33 guests